<<RIP_v1 routing protocol>>
================================================================================
- Distance Vector 이므로 전체정보를주기적으로갱신한다.
- Classfull
- RIP Timer
- Update Time : 30초
참고) Rip은 한번에 많은 양의 업데이트폭주를 방지하기위하여 Update시간의 15%
정도의 편차를 두어 Update를 실시! 이를 RIP Jitter라고한다.
- Invalid Time : 180초
-> 누락된 정보를 바로 지우는것이 아니라 없어진것이확실한것인지 유보시키는것..
- Holddown Time : 180초
-> Invalid Time후에 해당 네트워크가 삭제된후 해당 네트워크 정보가와도 무시
-> Looping을 막기 위해.
- Flushed Time : 240초
-> 완전삭제 될때 까지 걸리는 시간
예)
Update Time <----->
Invalid Time <----------------->
Holddown Time <----------------->
Flushed Time <------------------------>
- AD (Administrator Distance) : 120
- Metric : Hop-count (0-15) Rip은 Metric값 16을 수신하게되면 장애발생으로 인식(무한대)
예) R 192.168.5.0/24 [120/4] via 192.168.4.2 Update시간 interface(S0, E0..)
==> 5.0대역은 RIP으로 통신하며 4 hop이 떨어져 있고 S0으로 192.168.4.2의 Next
hop 이 xx:xx:xx시간전에 정보를 갱신해주었다.
- 로드분산 : 균등로드분산 지원(4~6)
-> 디퐅트가 4개 (1개는 로드분산 안한다는 의미!)
-> 하나의 목적에 대해서 하나의 경로만 표시 하는것이 기본인데
로드를 분산하기위해 한 목적지에 대해 다중의 경로를 표현해주는 것이다.
-> 균등 로드 분산 : 최적경로이고 Metric이 같을 경우만 적용된다.
-> 비 균등 로드 분산
- 업데이트 전송방식 : Broadcast (255.255.255.255) 방식을 쓴다.
================================================================================
<<RIP_v2 routing protocol>>
================================================================================
- 업데이트 전송방식 : Multicase (224.0.0.9) 방식을 쓴다.
-> uniscast 로 대체전송 가능하다.
- classless
- MD5인증기능 지원
Router(config)#router rip
Router(config-router)#version 2
Router(config-router)#no auto-summary
rackr1(config-router)#network 192.168.2.0
rackr1(config-router)#network 192.168.1.0
** 중요
- 기본적으로 auto-summary(classful하게)가 설정되어 있으므로 꼭 no auto-summary를 해주어야한다.
ex) 100.10.1.0 ~ 100.10.5.0 ==> 100.0.0.0 으로 자동 요약
Router#show ip route rip
R 198.140.162.0/24 [120/1] via 198.140.163.1, 00:00:03, Serial0/1
R 198.140.166.0/24 [120/1] via 198.140.165.3, 00:00:15, Serial0/0
================================================================================
<<Split-horizon>>
================================================================================
- Distance vector는 자신의 neighbor에게 정보를 무조건 전달하게 되어있으므로
기본적으로 같은 정보들이 돌아다니는 looping 현상이 발생하게 된다.
- 이를 막기위해 한 interface에서 받은 같은 정보는 그 interface로는 안보내야한다.
이를 split-horizon이라고 한다.
- 장비에서는 기본적으로 Distance vector routing protocol에 split-horizon이
설정되어있다.
- 설정 여부 확인 하기
r1#sh ip interface serial 0 로 split-horizon이 enable되어 있는지 확인하자!
================================================================================
<<RIP_v2 routing protocol - MD5 인증>>
================================================================================
- 라우팅 테이블을 전송해줄때, 그 상대가 정말 나와 연결되었던 믿을 수 있는 라우터
인지 검사하기 위해. 미리 세팅된 암호로 인증. 해킹을 방지 할 수 있다.
- key chain xxxx(key chain 이름)
- key xxxx(1~21억 의 key 숫자)
- key-string xxxx(key 문자열)
-> 즉, key chain은 대표이름이 key 숫자와 문자열을 묶어서 대표하는 것이다.
예)
Router(config)#key chain CCNA
Router(config-keychain)#key 1000
Router(config-keychain-key)#key-string cisco
Router(config-keychain-key)#interface serial 0/1
Router(config-if)#ip rip authentication mode md5
Router(config-if)#ip rip authentication key-chain CCNA
- R1~R2, R2~R3의 사이를 서로 다른 key chain으로 설정할 수 도 있다.
Router(config)#key chain CCNA2
Router(config-keychain)#key 3000
Router(config-keychain-key)#key-string cisco1234
Router(config-keychain-key)#interface serial 0/0
Router(config-if)#ip rip authentication mode md5
Router(config-if)#ip rip authentication key-chain CCNA
================================================================================
<<Passive-interface>>
================================================================================
- 여러 interface중 routing table 전송을 막기 위해 사용
- 해당 interface에 multicast와 broadcast 보내는 것을 막는다.
- 해당 interface로 부터 수신은 한다.
ex)
- passive-interface serial 0/1 (=> seiral 0/1로 보냄 막기)
- passive-interface default (=> 연결된 모든 interface막기)
- no passive-interface serial 0/1 (=> seiral 0/1로 보냄 막음 풀기)
================================================================================
<<RIP_v2 routing protocol - 전송방식을 Unicast로 전환>>
================================================================================
- 연결된 interface중 다르 routing protocol을 쓰는 interface로 routing table송신
을 막을 때 쓴다.
예)
Router(config)#router rip
Router(config-router)#passive-interface serial 0
Router(config-router)#neighbor 172.16.111.2
================================================================================
<<하나의 interface에 여러게 ip 넣기>>
================================================================================
- loopback 인터페이스를 여러개 만들기 안고 network/ip를 여러게 넣기
- 처음 주소는 secondary 안쳐준다!
Router(config)#interface loopback 0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config-if)#ip address 10.1.2.1 255.255.255.0 secondary
Router(config-if)#ip address 10.1.3.1 255.255.255.0 secondary
Router(config-if)#ip address 10.1.4.1 255.255.255.0 secondary
:
Router(config-if)#ip address 10.1.8.1 255.255.255.0 secondary
================================================================================
<<RIP_v2 routing protocol - CIDR>>
================================================================================
- 여러 네트워크를 요약한 routing table로 전송하라
Router(config-if)#interface serial 0
Router(config-if)#ip summary-address rip 10.1.0.0 255.255.240.0
- 주의! 요약하면 안되는 경우
- 같은 대역 여러군에 있을 경우 요약 안됨
ex) R1쪽에 10.1.1.0 ~ 10.1.3.0
R3쪽에 10.1.5.0 ~ 10.1.9.0
- RIP_v2는 superneting 이 안되므로 C클래스에서 다음과 같이 하려면 안된다.
ex)
Router(config-if)#ip summary-address rip 193.168.1.0 255.255.240.0
Summary mask must be greater or equal to major net
================================================================================
<<RIP routing protocol - version 두개가 혼동되어있을 경우>>
================================================================================
- v2와 v1은 기본적으로 통신이 안된다.
- 통신이 되게 하려면 v2를 쓰는 라우터 쪽 인터페이스에서 v1으로 보내고 받도록
설정해주어야한다.
- interface S 0/0
- ip rip send version 2
- ip rip receive version 2
================================================================================
<<RIP routing protocol - 로드분산>>
================================================================================
- 한 목적지에 대해 최적경로가 두개 있을 경우 경로 두개 모두 표시
예) 177.48.96.176 로 가는 경로가 로드 분산 되었다.
153.168.0.0/26 is subnetted, 3 subnets
R 153.168.238.192 [120/1] via 177.48.96.170, 00:00:22, Serial0
R 153.168.238.128 [120/1] via 192.168.1.3, 00:00:17, Serial1
C 153.168.238.64 is directly connected, Ethernet0
177.48.0.0/30 is subnetted, 2 subnets
C 177.48.96.168 is directly connected, Serial0
R 177.48.96.176 [120/1] via 177.48.96.170, 00:00:22, Serial0
[120/1] via 192.168.1.3, 00:00:17, Serial1
C 192.168.1.0/24 is directly connected, Serial1
- maximum-paths 명령으로 로드분산 경로수를 조절할 수 있다.
예) 위의 예에서 다음과 같이 치면
Router(config-router)#maximum-paths 1
153.168.0.0/26 is subnetted, 1 subnets
C 153.168.238.64 is directly connected, Ethernet0
177.48.0.0/30 is subnetted, 1 subnets
C 177.48.96.168 is directly connected, Serial0
C 192.168.1.0/24 is directly connected, Serial1
================================================================================
'Networking' 카테고리의 다른 글
5. ACL (0) | 2015.01.24 |
---|---|
5. ACL - Wildcard Mask 문제 (0) | 2015.01.24 |
4. IGRP (0) | 2015.01.24 |
2. 라우팅 프로토콜 개념 (0) | 2015.01.24 |
1. 라우터 기본 명령어 (0) | 2015.01.24 |